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Service Portal approval form update error - Support and Troubleshooting
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KB0864762

Service Portal approval form update error


1583 Views Last updated : May 28, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

On the Approval form, when selecting the Approval button on a change request, an update error occurs. 

Release

Confirmed on Paris

Cause

ServiceNow has changed the technical and role requirements for users to be able to process approvals. The following logic within the Approval Info widget now requires at least the approver_user role.

See line 11 in server script of the widget code:

https://<your instance>.service-now.com/sp_widget.do?sys_id=33442352cb30020000f8d856634c9c3f

var userApprovalAccess = gs.hasRole("approval_admin") || (gs.hasRole("approver_user") && data.isMine);

Resolution

Try adding the role approver_user to the user, or you can modify the widget where this condition has been included.
As the user does not have any roles, it redirects to Service Portal and the 'approver_user' role is needed for processing the approvals.


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