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How to remove info message 'Switch to updated version of this page (recommended)' from 'Create New' in Knowledge - Support and Troubleshooting
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  • How to remove info message 'Switch to updated version of this page (recommended)' from 'Create New' in Knowledge
KB0863622

How to remove info message 'Switch to updated version of this page (recommended)' from 'Create New' in Knowledge


1663 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

In Knowledge application, there is a requirement to remove or disable the info message 'Switch to updated version of this page (recommended)' from the 'Create New' module and Knowledge Homepage.

Cause

As per the expected behaviour in the platform, the first time the user clicks in the 'Create New' or 'Create an Article' (from the Knowledge home page), the message 'Switch to updated version of this page (recommended)' will be displayed to the user.

After clicking at the message, the interface will change and an entry will be created in the 'sys_user_preference' table based on the 'kb_interceptor' user preference.

User Preferences
https://<instance-name>.service-now.com/sys_user_preference_list.do?sysparm_query=nameLIKEkb_interceptor&sysparm_view=

Once the user preference record gets created, next time the same user tries to create an article it will use the new interface and the message won't be displayed.

Resolution

If you want to use the new version of the page:

For the 'Create New' filter navigator menu, you can update the URL through the 'Module' record so that the interceptor will automatically switch to the new template version once user clicks 'Create New'.

This can be done by following the steps below:

1. Open the 'Create New' module record from the below URL (replacing the <instance-name> by the name of your instance)
https://<instance-name>.service-now.com/nav_to.do?uri=sys_app_module.do?sys_id=d78ed921ff4221009b20ffffffffffdf 

2. In the 'Link Type' related list, change the Arguments field to:
knowledge_create.do?sysparm_stack=kb_knowledge_list.do&sysparm_interceptor_preference=new

The same however, can't be done at the 'Create an Article' button in the Knowledge home page ($knowledge.do), as this UI page is an angular page held service side which is not customer accessible and hence it cannot be changed.

If you want to use the old version of the page:

If you just want to remove the message and continue using the old version of the page, you can review the Processor record 'KnowledgeCreateLauncher':

KnowledgeCreateLauncher
https://<instance-name>.service-now.com/nav_to.do?uri=sys_processor.do?sys_id=cd2ad1ee87132300420e5cdac5cb0b63


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