Issue
Reset Password in user profile and got an error msg "Password Reset Error - General error. Contact the service desk for assistance."
Cause
- Looked into the Flow Engine Context table 'sys_flow_context' to locate the password reset error correspond to the timestamp we execute the password reset
- Open the context in Operation View
- In the Flow Designer you will see in the get lock process the following error:
Error: User Name should not be empty (sys_script_include.c2bb80aa73126300039a2ea3c4f6a721.script; line 20)
Resolution
Open 'sys_user' table and locate this same user, you will see the user_id is empty. Update the user 'user_id' field and it will fix this issue.