Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
password reset failed with error 'User Name should not be empty' - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • password reset failed with error 'User Name should not be empty'
KB0863151

password reset failed with error 'User Name should not be empty'


504 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Reset Password in user profile and got an error msg "Password Reset Error - General error. Contact the service desk for assistance."


Cause

- Looked into the Flow Engine Context table 'sys_flow_context' to locate the password reset error correspond to the timestamp we execute the password reset

- Open the context in Operation View 

- In the Flow Designer you will see in the get lock process the following error:

Error: User Name should not be empty (sys_script_include.c2bb80aa73126300039a2ea3c4f6a721.script; line 20)


Resolution

Open 'sys_user' table and locate this same user, you will see the user_id is empty.  Update the user 'user_id' field and it will fix this issue.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.