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Request is not created for an inbound email action logging error "com.glideapp.servicecatalog.exceptions.CartException: Your cart has item(s) no longer available. Please remove <CATALOG_ITEM> from cart to continue with the checkout" - Support and Troubleshooting
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  • Request is not created for an inbound email action logging error "com.glideapp.servicecatalog.exceptions.CartException: Your cart has item(s) no longer available. Please remove <CATALOG_ITEM> from cart to continue with the checkout"
KB0862997

Request is not created for an inbound email action logging error "com.glideapp.servicecatalog.exceptions.CartException: Your cart has item(s) no longer available. Please remove <CATALOG_ITEM> from cart to continue with the checkout"


3819 Views Last updated : May 10, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

An inbound email action fails to create a service catalog request. The following error message is displayed in the node log:

*** WARNING *** Evaluator: com.glideapp.servicecatalog.exceptions.CartException: Your cart has item(s) no longer available. Please remove <CATALOG_ITEM> from cart to continue with the checkout.

Release

Since Paris, access check for a catalog item is performed during its checkout. This check is also applicable in scripts and APIs.

Cause

The catalog item which is being submitted has an user criteria defined on it. The integration user who submits the item does not have the necessary role mentioned in the user criteria, or does not match other conditions in the criteria. Hence the request can not get created.

Resolution

Add the necessary role to the integration user and review the user criteria.


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