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Description

When the user was creating a SLA Definition in environment 'A', upon trying to move it to environment 'B', the SLA Definition did not trigger (whether the movement was by update set or direct XML import does not matter).

Cause

This issue is documented in PRB1391147.

Resolution

The issue the user was facing was a direct result of the SLA Commitments plugin being installed on environment 'A' but not on environment 'B' (ID = com.snc.service_portfolio.sla_commitment).

When moving a contract_sla (SLA Definition) record from environment 'A' to 'B', the commitments field does not exist in environment 'B', so it's actually left as null in the database. Null translates to false when as per viewing the data, but it fails on querying the database.

To fix this issue, the discrepancy needs to be addressed. If the plugin shouldn't be active on environment 'A', it should be cloned from Production to fix this issue. If it should be active, then environment 'B' needs the plugin activated to "sync" the instances (i.e. both instances should have the plugin set to "true") and thus allow a seamless transferring of SLA Definitions via Update Set or direct XML import from A > B, and B > A.

Article Information

Last Updated:2020-10-20 23:28:35
Published:2020-10-17