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No Preview Available for HR profile but user has read access to the HR profile record itself - Support and Troubleshooting
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  • No Preview Available for HR profile but user has read access to the HR profile record itself
KB0860685

No Preview Available for HR profile but user has read access to the HR profile record itself


815 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Group members cannot preview or open the HR profile of opened for or subject person in "sn_hr_core_case" table.

When user clicks the reference icon next to the name, it comes up with "No Preview Available"

Cause

On clicking on preview field the following method is eventually called:
Script include : sn_hr_core.hr_CaseAjax
Method : getGlideRecordSecureSetData

This returns all the HR Profile fields that the logged in user has canRead access to :

_getData: function (gr) {
var data = {};
var elements = gr.getElements();
for (var i = 0; i < elements.length; i++) {
if (!elements[i].canRead())
continue;
var ed = elements[i].getED();
var name = ed.getName();
data[name] = gr.getValue(name);
}
data['ZZ_YY_display_value'] = gr.getDisplayValue();
return data;
},

According to the above code if any of the HR Profile fields do not pass canRead they will not be populated in the data returned.



Resolution

There is an out-of-box (OOB) ACL such the sn_hr_core_profile.* access is given to sn_hr_core_profile reader and all the OOB Assignment group members have that role and hence this issue is not seen.

This ACL could have been modified


Make sure to:

Create/Modify ACL with sn_hr_core_profile.* such that access is give to the intended user.

Check if the read ACL for sn_hr_core_profile was customized and revert it to OOB:
https://<instance_name>.service-now.com/nav_to.do?uri=sys_security_acl.do?sys_id=3e5370019f22120047a2d126c42e7001



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