Notifications

27 views

Description

Form >  'Open a new form/ Open an Existing Record' step doesn't work for a new custom agent workspace with his own scope

Steps to Reproduce

This can be reproduced on any table, "incident" is used as an example


Prerequisite: Create Custom Workspace

1)Navigate to Studio >> Create Application

2) Input any name and click "Create"

3) Select any role and click "Continue"

4) Select "Workspace" and click "Continue"

5) Click "Done with Table" and click "Start"

6) Click "Continue" and select "Single Page Navigation" and click "Continue"

7) Once it's done click "Open"


Now


1) Navigate to Automated Test Framework >> test module

2) Click "New", input any name and click "Save"

3) Click "Add Test Step", navigate to "Form", select "Open an Existing Record", and click "Next"

4) Set Form UI to <Custom Workspace> created above, table to "incident" and select any record of "incident table",  then click "Submit"

5) Click "Run Test",


Expected: Test should succeed and should open a record in the custom workspace
Observed: Test fails with output that looks something like this: The page you are looking for could not be found.


Workaround

There is no available workaround for custom workspaces at this time.


Related Problem: PRB1418619

Seen In

There is no data to report.

Intended Fix Version

Quebec

Safe Harbor Statement

This "Intended Fix Version" information is meant to outline ServiceNow's general product direction and should not be relied upon in making a purchasing decision. The information provided here is for information purposes only and may not be incorporated into any contract. It is not a commitment, promise, or legal obligation to deliver any material, code, or functionality. The development, release, and timing of any features or functionality described for our products remains at ServiceNow's sole discretion.

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2020-10-02 17:50:00
Published:2020-10-03