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Demand Stakeholder Register Unique Key Violation issue - Support and Troubleshooting
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  • Demand Stakeholder Register Unique Key Violation issue
KB0860466

Demand Stakeholder Register Unique Key Violation issue


342 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Demand Stakeholder Register Unique Key Violation issue

Cause

That this issue was happening because the users were trying to add Demand Stakeholder Registers in an unsupported way and have customized the Business Rule that will prevent you from performing the action you are taking.

A user is only able to be listed in the Stakeholder Register 1 time for each Portfolio. If there are duplicates, it is not allowed.

I would recommend reverting the "Validate" Business Rule that runs on the 'dmn_stakeholder_register' table.


Resolution

Next Steps:

1. Navigate to System Definition > Business Rules
2. In the Name column search for "Validate" and in the Table column search for "dmn_stakeholder_register". Go to the record
3. In the Versions related list, Right-Click the record with the Source of "System Upgrades: glide-VERSIONNAME..."
4. Select "Revert to this version"
5. Select OK when prompted


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