Issue
Sometimes users notice the message "Please wait while all the fields are loaded and run the report again" while creating the trend reports when it is unable to find a valid field for "Trend by" by default.
Steps to Reproduce:
- Create a new report.
- In the Data tab select a table [Easy to reproduce with a view].
- Select report type Column or Trend.
- Click next.
Notice that it shows the message 'Please wait while all the fields are loaded and run the report again'.
Release
All Releases
Cause
The system will automatically set a field for "Trend by" by automatically by finding a Date/Time type field like created, updated, closed, activity due, etc... However in rare scenarios, if there is no date/time type field on the selected table/DB view it will automatically set a non Date/Time type field for "Trend By".
Resolution
- Please navigate to the "Configure" tab once you select the report type.
- Select "Trend By" --> If there are no date/time type fields, Dot walk to any of your desired fields like closed, created, updated, activity due, etc..
- Run the report.