Issue
Some child incidents aren't being moved to the resolved state after their parent incident is resolved.
Release
All
Cause
There was a custom business rule with an abort action that was triggered during the 'Update Child Incidents' BR update because some of the incidents were unassigned therefore, the update was canceled for all of the incidents after the unassigned incident.
Resolution
You can make sure the child incidents don't trigger the BR with the abort action or you could disable the custom BR.