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Emails sent from custom SMTP email account ProofPoint get stuck in a send-retry loop - Support and Troubleshooting
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KB0860057

Emails sent from custom SMTP email account ProofPoint get stuck in a send-retry loop


2344 Views Last updated : Sep 16, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Emails having attachments sent from a custom ProofPoint email account are at times stuck in a send-retry loop, and actually get sent many times.

One symptom is the following warning traced in a node log when the email is sent:

2020-09-07 07:46:28 (966) worker.7 worker.7 txid=f2294aaadb4f WARNING *** WARNING *** handling smtp exception: javax.mail.MessagingException: Exception reading response;
nested exception is:
java.net.SocketTimeoutException: Read timed out : Exception reading response
2020-09-07 07:46:28 (973) worker.7 worker.7 txid=f2294aaadb4f WARNING *** WARNING *** EMAIL.b0f70ea6db4f54d09a686b4bd39619c8: send-retry

This makes the administrator believe that the instance might not be waiting a long enough timeout to receive a response from a mail server.

Release

All

Cause

The SMTP timeout duration is something that ServiceNow set at code level and we cannot modify it. The default SMTP timeout is 60 seconds and the default SMTP max timeout is 300.

From the ServiceNow side the step to take is to validate if there is any business rule with current.update in the target or sys_email table.

The use of current.update is discouraged:
Recommended Practices in Using current.update() in Business Rules
Avoid using current.update() in a business rule script

Resolution

Usually, the loops stop by removing the attachment from the sys_email record. As ProofPoint is not a ServiceNow product and the issue occurs when using an external mail server, it is required to work with the email admin to examine the logs and troubleshoot further.
 
The solution has eventually worked by regular testing with a process of elimination, troubleshooting and narrowing down if the formatting of the messages is affecting the ProofPoint ability to allow the messages to be processed. For example, replacing <strong> with <b>, could help the messages to start going through without delay.
It could be something as easy as that or much more complex. Here is a list of external links outside ServiceNow scope that mentions this issue:

https://www.proofpoint.com/sites/default/files/essentials_administrator_guide_for_end-customers_cm.pdf

https://mso.harvard.edu/faq/i-have-email-attachment-was-delayed-proofpoint-what-happens-my-email-during-5-7-minute-delay#:~:text=delayed%20by%20Proofpoint.-,What%20happens%20to%20my%20email%20during%20the%205%2D7%20minute,email%20and%20attachment%20are%20blocked.

https://help.proofpoint.com/Proofpoint_Essentials/Email_Security/Administrator_Topics/110_logs/Troubleshooting_email_delivery_problems_using_Email_Logs

https://www.uml.edu/docs/Secure%20Email%20FAQs_tcm18-237100.pdf

https://help.proofpoint.com/Proofpoint_Essentials/Email_Security/Administrator_Topics/110_logs/Understanding_Email_Logs

Related Links

Slow outbound email processing when own SMTP server is used

Custom SMTP Server fails sending emails with error "Local address contains control or whitespace"

Outbound emails are failing with invalid addresses blocked by Spamhaus with custom configured SMTP Server


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