Issue
If you have an issue where email Notifications are not being fired, meaning there are no Events[sysevent] or Emails[sys_email] being generated, it may be because 'engines' used to generate emails, among other things, are disabled. It's sometimes been seen that custom Business Rules (BRs) deployed on customer instances use one or both of these GlideRecord functions, that when run, suppress Workflows or other internal 'engines' from running during an update or insert operation:
setWorkflow(false)
setUseEngines(false)
Release
All ServiceNow versions
Cause
Disabling the Notification Engine with either of these functions prevents Notification emails from being generated.
Resolution
If the customer has a BR that uses setWorkflow(false) or setUseEngines(false) they can still run it, but it *must* be run as an after BR with an Order of 1001 or greater, see Execution order of scripts and engines.
NOTE: Remember to set back to 'true' after a current.update() in a business rule: setWorkflow(true), in a line after setWorkflow(false); current.update(), in order for business rules and other engines to run again.
Related Links
setUseEngines: GlideRecord-setUseEngines_Boolean
setWorkflow: GlideRecord-setWorkflow_Boolean