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Description

When logged in as an external customer on CSM/CSP portal, if you click on an attachment,

Either the document viewer might NOT open

OR

the document viewer opens but the article is NOT rendered (its blank).

Release or Environment

Orlando. 


Cause

There are 2 reasons for it.

1. System property that enables document viewer for service portal is FALSE

2. The script that renders the document viewable only allowed to be run for Internal.

Resolution

1. Create the below system property (if doesn't exist) and set it to TRUE

glide.knowman.use_document_viewer

sn_km_portal.glide.knowman.serviceportal.use_document_viewer


2. Create below ACL for the given process to make sure snc_external / sn_esm_user are allowed to run that process.




Article Information

Last Updated:2020-09-04 04:38:04
Published:2020-09-04