Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Outboud REST API always fails with timeout | Troubleshooting - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Outboud REST API always fails with timeout | Troubleshooting
KB0855359

Outboud REST API always fails with timeout | Troubleshooting


3221 Views Last updated : Dec 21, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

This troubleshooting article contains information about why a REST API may continually time out.

Symptoms

  • An outbound REST API was built to access a remote system via MID server.
  • When the API is called either by script or manually, it always fails with the specified 60 seconds of API timeout.
  • The system log may show that was an error in processing the response body, and this is because after the timeout happens there is no response body.

Release

Any supported release

Cause

The continual REST API timeout occurs when the MID server is down, caused by the REST probes timing out. This may happen if your instance was upgraded, but the MID servers are still in an older release.

Resolution

Always check that the HTTP Call is set to use a MID server which is up and running. Otherwise, you may notice a REST API timeout. 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.