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Description

We are trying to make a knowledge article viewable to the public but when the user goes to the link you may see the following:
http://<your instance>/sp?id=kb_article&sys_id=471ee81eff6002009b20ffffffffff34



Or you may see something like this:


Release or Environment

Confirmed in Orlando

Cause

There are two factors that can be missed that can cause the above issues:

1. If the knowledge base does not have any read criteria make sure to set the to false: glide.knowman.block_access_with_no_user_criteria

2. Make sure that the following service portal pages kb_home, kb_article_view and kb_search are all set to public.
https://docs.servicenow.com/bundle/orlando-servicenow-platform/page/product/knowledge-management/task/make-knowledge-visible-to-public.html

Resolution

To set the system property do the following:

  1. Go to the http://<your instance>/nav_to.do?uri=sys_properties.do?sys_id=b8a2fb1acbb400108ad442fcf7076d9d
    2. Set the value from true to false

To set the pages to public do the following:

  1. Go to http://<your instance>/sp_page_list.do?sysparm_query=id%3Dkb_home%5EORid%3Dkb_article_view%5EORid%3Dkb_search&sysparm_view=
    op
  2. Open each page and make sure to turn set Public to true

Article Information

Last Updated:2020-08-27 09:03:27
Published:2020-08-27