Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
VTB is not honouring any Client script, defined on the underlying records - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • VTB is not honouring any Client script, defined on the underlying records
KB0854399

VTB is not honouring any Client script, defined on the underlying records


555 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Client scripts are not getting triggered when the action to initiate is been performed from VTB. This works fine in the native UI or Service Portal.


Steps To Reproduce:

1) Log onto OOB instance
2) Create new client script on problem table as below
Type: onChange
Table: Problem
Field name: state
Script:

function onChange(control, oldValue, newValue, isLoading, isTemplate) { 
if (isLoading || newValue == '') { 
return; 
} 
if (!isLoading) { 
if (newValue != ''){ 
g_form.setMandatory('work_notes',true); 
} 
} 

}

3) Go to problem list and "show match" a single record
4) Right-click the state column and "Show visual task board"
5) Move the task from the current state to another state
-Expected: pop up window should say "A UI Policy has prevented you from making a change" 
-Actual: the update is allowed

Cause

VTB is not designed to honour Client Scripts.

Resolution

UI and/or Data Policies are the appropriate approaches to inform VTB of required fields.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.