Issue
Client scripts are not getting triggered when the action to initiate is been performed from VTB. This works fine in the native UI or Service Portal.
Steps To Reproduce:
1) Log onto OOB instance
2) Create new client script on problem table as below
Type: onChange
Table: Problem
Field name: state
Script:
function onChange(control, oldValue, newValue, isLoading, isTemplate) {
if (isLoading || newValue == '') {
return;
}
if (!isLoading) {
if (newValue != ''){
g_form.setMandatory('work_notes',true);
}
}
}
3) Go to problem list and "show match" a single record
4) Right-click the state column and "Show visual task board"
5) Move the task from the current state to another state
-Expected: pop up window should say "A UI Policy has prevented you from making a change"
-Actual: the update is allowed
Cause
VTB is not designed to honour Client Scripts.
Resolution
UI and/or Data Policies are the appropriate approaches to inform VTB of required fields.