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Workflow stuck because ECC queue input record is not processed - Support and Troubleshooting
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  • Workflow stuck because ECC queue input record is not processed
KB0853652

Workflow stuck because ECC queue input record is not processed


1688 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Workflows can have activities which make calls to MID servers, this could be to run a RESTProbe for example. Such calls are made by creating output records in the ecc_queue table. The workflow will not continue if the input ecc_queue, created by the MID Server as a response to the ecc_queue output record, stays in "Ready" state or "Error".

To confirm the issue is due to an ecc_queue input record

  1. Open the workflow context record, wf_context
  2. Under related links, click on link "ECC Queue" to see the ecc_queue records for the context
  3. Click on the ecc_queue record where state = "Ready"
  4. Download attachment in the ecc_queue record
  5. Check size of attachment

Note: If the ecc_queue record with state = "Ready" is in the output queue, the issue is likely on the MID server and MID server logs should be reviewed.

Release

All currently supported releases.

Cause

Large Attachment

Ecc_queue input record has an attachment which is larger than allowed.

Resolution

Large Attachment

Set sys_property com.glide.attachment.max_get_size to a value larger than the size of the attachment in the ecc_queue input.

FieldDescription
Namecom.glide.attachment.max_get_size
TypeInteger
Default5242880

Note: 5242880 is equals 5 MB.


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