Issue
Workflows can have activities which make calls to MID servers, this could be to run a RESTProbe for example. Such calls are made by creating output records in the ecc_queue table. The workflow will not continue if the input ecc_queue, created by the MID Server as a response to the ecc_queue output record, stays in "Ready" state or "Error".
To confirm the issue is due to an ecc_queue input record
- Open the workflow context record, wf_context
- Under related links, click on link "ECC Queue" to see the ecc_queue records for the context
- Click on the ecc_queue record where state = "Ready"
- Download attachment in the ecc_queue record
- Check size of attachment
Note: If the ecc_queue record with state = "Ready" is in the output queue, the issue is likely on the MID server and MID server logs should be reviewed.
Release
All currently supported releases.
Cause
Large Attachment
Ecc_queue input record has an attachment which is larger than allowed.
Resolution
Large Attachment
Set sys_property com.glide.attachment.max_get_size to a value larger than the size of the attachment in the ecc_queue input.
Field | Description |
Name | com.glide.attachment.max_get_size |
Type | Integer |
Default | 5242880 |
Note: 5242880 is equals 5 MB.