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Catalog task (sc_task): Form goes partially unresponsive after previewing a Reference field - Support and Troubleshooting
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  • Catalog task (sc_task): Form goes partially unresponsive after previewing a Reference field
KB0853644

Catalog task (sc_task): Form goes partially unresponsive after previewing a Reference field


761 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

  • Catalog task (sc_task): Form goes partially unresponsive after previewing a Reference field. It happens only few catalog tasks form.

Cause

  • The reference field's table:Requested item, is configured with Variable editor on its sys_popup view.
  • If there are any client scripts/ui policies configured on the variables (Requested Items), they will try to execute even when loading the variable editor on sys_popup view and won't get executed, this will cause for the issue

Resolution

  • To resolve the issue, remove the variable editor from the sys_popup view. More info on this procedure can be found in https://docs.servicenow.com/csh?topicname=c_ReferenceIcon.html&version=latest#t_FieldsDisplayed
  • If there is no sys_popup view exists for the table: sc_req_item, it will load the Default form view of sc_req_item. It is always recommended to create a sys_popup view without a variable editor.

Related Links

  • Sometimes, the issue might occur due to the custom ui macro (formatter) or script include assigned with the Reference field's dictionary or on the form layout.

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