Issue
In Service Portal, when accessing a page containing date variables, the date selector does not appear.
Release
All releases
Cause
This issue occurs when a customized theme being used.
Resolution
To solve this, revert the theme in the portal record (sp_portal) to the default theme.
You can check to see if the issue is related to a theme being used in the portal, or related to CSS includes in theme or JS Includes:
Verify if the issue is happening in $sp.do. To do this, replace portal suffix in URL from /sp to $sp.do.
If issue does not happen there, make sure that the theme and portal configuration are correct or if any customizations are present.
If issue happens in $sp.do as well, other configurations need to be checked.