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Intermittently, request item service catalogue notification does not get sent - Support and Troubleshooting
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  • Intermittently, request item service catalogue notification does not get sent
KB0852976

Intermittently, request item service catalogue notification does not get sent


815 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

This issue exists in a context where a custom notification is created that sends out an email to notify that a request item was created for a 'requested for' user.

When a recipient "Request.Requested_for" is added as the only one recipient, intermittently, the Email does not get sent with state shown as ignored.

Note that the recipient is a 'dot walk' to the related Request record that contains the field 'Requested_for"

If there are other recipients, the email would get sent out but the requested for recipient would e missing.




Release

Any

Cause

This issue is caused because of the timing sequence when events are processed

Event  "sc_request.inserted" can get  processed around 4 or 5 seconds after event "sc_req_item.inserted".

Therefore, at the time the event "sc_req_item.inserted" gets processed, the related request record does not have the requested for value yet and the email cannot be sent if no recipient exists,

Resolution

In a scenario when you are using the service catalogue  and a custom notification that has a 'dot walked' recipient to the related Request record, then use the following workaround.


  •  Edit the out of the box workflow "Service Catalog Request" as show below


  •  Add a new Timer activity (default settings) after the Begin Activity and 'the X=Set Values' activity




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