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Flows with REST/SOAP Step fail with error relating to "Response size exceeds limit" - Support and Troubleshooting
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KB0852968

Flows with REST/SOAP Step fail with error relating to "Response size exceeds limit"


7556 Views Last updated : Feb 26, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

For the latest information, see https://docs.servicenow.com/csh?topicname=rest-request-action-designer&version=latest

For a given response payload from a REST or SOAP step it is possible that it can exceed the default payload size.

The execution context would contain an error like the following:

..failed with error: com.snc.process_flow.exception.OpException: Response size exceeds limit, allowed :xxxxx actual size: xxxxx

Cause

By default, the allowed payload size for a REST or SOAP response is 5MB (5120KB).

Resolution

To address that error message, add the respective properties to the [sys_properties] table for the given step being used.

REST:
glide.pf.rest.response_payload_max_size

SOAP:
glide.pf.soap.response_payload_max_size

Note 1: Please note that the value is in KB, so 10MB = 10240 (10 * 1024KB).
Note 2: If the respective flow is configured to use a MID Server, you would add the respective property to the MID Server properties table and not [sys_properties].


The maximum value that can be specified is: 10240

If the response attachment is more than 10MB, then the Flow Action will need to utilise "Save As Attachment" (under "Response Handling").


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