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Known error database knowledge base field is defaulting to null - Support and Troubleshooting
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  • Known error database knowledge base field is defaulting to null
KB0852783

Known error database knowledge base field is defaulting to null


1183 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When clicking on "Create Known Error article" from a problem record, the following error is returned

Apply default values: null

Also, the Knowledge Base is not populated

Cause

The dictionary entry or dictionary override of kb_knowledge.kb_knowledge_base field was customized

This dictionary is also having a default value pointing to the property "problem.knowledgebase.known_error_article"

This property contains the default sys_id for the "Known Error" knowledge base which is "c0a54bac871023000e3dd61e36cb0bcb" by default

If this sys_id is not in your instance or you deleted the out-of-box (OOB) knowledge base, then the issue can occur


Resolution

Check the dictionary entry or dictionary override entry for the field kb_knowledge_base in the kb_knowledge table and revert it to OOB if customized


Check the property "problem.knowledgebase.known_error_article" and make sure that the sys_id is pointing to an existing Known error knowledge base



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