Issue
When clicking on "Create Known Error article" from a problem record, the following error is returned
Apply default values: null
Also, the Knowledge Base is not populated
Cause
The dictionary entry or dictionary override of kb_knowledge.kb_knowledge_base field was customized
This dictionary is also having a default value pointing to the property "problem.knowledgebase.known_error_article"
This property contains the default sys_id for the "Known Error" knowledge base which is "c0a54bac871023000e3dd61e36cb0bcb" by default
If this sys_id is not in your instance or you deleted the out-of-box (OOB) knowledge base, then the issue can occur
Resolution
Check the dictionary entry or dictionary override entry for the field kb_knowledge_base in the kb_knowledge table and revert it to OOB if customized
Check the property "problem.knowledgebase.known_error_article" and make sure that the sys_id is pointing to an existing Known error knowledge base