Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Catalog UI policy not working correctly on an item page - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Catalog UI policy not working correctly on an item page
KB0852355

Catalog UI policy not working correctly on an item page


452 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

There is a Catalog UI policy which should hide a variable based on the value of another variable. Instead the variable is getting displayed all the time on the item page.

Cause

  • Catalog UI policy that is responsible for hiding the variable has policy actions which are referencing the old variables which no longer exist as these variables were removed and later recreated with the exact same name. Even though their internal name remains the same their sys_ids will be different.
  • Since UI policy actions refer to the variable using their sys_id, which is still referencing the old variable's 'sys_id' and not the new variable's sys_id

Resolution

  • Go to the corresponding Catalog UI policy
  • Delete the existing UI policy actions which are still referring to the old variables[before deleting check out their sys_id by opening the UI policy action in a separate tab]
  • Create new UI policy actions so that correct sys_id of the newly created variable is referenced



The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.