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ServiceNow Company Normalization - Duplicate Company - Support and Troubleshooting
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KB0852264

ServiceNow Company Normalization - Duplicate Company


5178 Views Last updated : Jul 12, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

There are duplicate company names in the "core_company" table.

The "Hash" field value in the "core_company" list view is the same.

- Check on the "Hash" field value of the duplicate company records.

Release

All

Cause

The "core_company" table [sys_db_object] record, the 'hash' field does not exist in the "Database Indexes" related list.

Note: The highlighted Index is missing.

Resolution

To be able to add the 'hash' index, please see the steps below: 

  1. Navigate to the System Definition > Tables & Columns
  2. Look for the 'Company [core_company]' from the list of 'Table Names' and select it.
  3. Once the table is selected, Scroll down to the 'Index creator' section.
  4. Select 'Hash' from the "Available' bucket and move it to the 'Selected'
  5. Select the 'Unique Index' checkbox.
  6. Click 'Create Index'.


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