Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
MID server failing pre-upgrade checks - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • MID server failing pre-upgrade checks
KB0851963

MID server failing pre-upgrade checks


4185 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Midserver upgrade failed with the error statement "Aborting MID Server upgrade due to pre-upgrade check failure: Service snc_mid does not exist"

Cause

The Wrapper override configuration had missing Midserver Display name which was reporting unresolved issues for Midserver.By checking this file, I found the missing configuration and suggested customer to change the configuration as below. The reason behind is, Wrapper name somehow got modified at customer Midserver Wrapper Override file. As there was no name found, while Pre-upgrade check happens instance unable to identify the servicename of Mid and eventually failed the pre-upgrade check. 

Resolution

With the error statement, we need to first take a look on Wrapper Override config file to check the configuration is correct or somehow it got changed/or modified.  Its better to always ask customer to share all the Midserver config files(config.xml+wrapper-override.xml) with the Logs(Agent+wrapper). Post investigation, I observed wrapper-Override had missing wrapper.name which need to modify. 

Midserver configuration as per Wrapper Override per customer instance initially:-
====================================================================


# The following properties must be unique per MID installed on the same system.
#
# REQUIRED: Name token of the service
wrapper.name=snc_mid
# REQUIRED: Display name of the service
wrapper.displayname=ServiceNow MID Server

Suggested configuration for the Midserver Wrapper Override file :-(If there are multiple MID servers on the same host.)
===================================================================================================

# REQUIRED: Name token of the service
wrapper.name=snc_mid_XXXX
# REQUIRED: Display name of the service
wrapper.displayname=ServiceNow MID Server


Note:- XXXX-stands for the name of the Midserver which you are working as per config.xml.


After that, save the file and restart the MID service for the changes to take effect. Wait about 10 minutes and inspect the MID server once again in the instance. This will fix the error and Mid server Pre-upgrade check will happen successfully. 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

Attachments

Attachments

  • Screen Shot 2020-07-24 at 9.42.18 PM.png
  • wrapper-override.conf_WGpvSNMD01_dev.grabLog.xml.gz

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.