Issue
- A business rule has been setup to sync additional comments from SC_TASK to RITM level
- However, the Requested item notification does not trigger and get send as expected, when commenting on an SC_TASK
- Commenting directly on the RITM triggers the notification as expected.
- Same behaviour is reproducible when there is a comment synchronisation between different records.
Cause
- The notification is getting evaluated before the RITM gets updated . It usually happens due to the "Record Inserted or Updated" event.
Resolution
- Always create an event based notification when using business rules, so it will trigger the event and therefore the notification will generate the sys_email. record. It requires three steps:
- Create an event
- Create an email notification with appropriate details in the subject and body
- Send to event Creator - checked
- Sent on trigger of event and add event name that was created
- Send to even param 1 and 2 -
- On the Business Rule, trigger the event (using gs.eventQueue('event name'), current, event param1, event param2)
- Always test on dev before applying any change on production. For event driven notifications, there are examples in the community such as the next link: