Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Confirmation message popup appearing when navigating from a form without any change - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Confirmation message popup appearing when navigating from a form without any change
KB0831223

Confirmation message popup appearing when navigating from a form without any change


1838 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When customer opened an existing record and then tries to move away from the firm, without making any change, still the browser gives a message popup that 'Do you want to save changes' and askes for Save or leave.

Cause

This may have caused by a UI Policy action, which has a checkbox for 'Clear The field value' checked.

While on load, a UI policy was hiding a few fields, but at the same time clearing the value. This is triggering an internal this.modified call as the value of these fields are getting changed on the form. That is why when the user is trying to navigate away from the form, it is asking the confirmation popup, as in backend for these fields the values are changed.

Resolution

The customer needs to review the UI Policy actions. The easiest option is to uncheck the 'Clear The field value' field.

Related Links

You can find the source of this by searching for this.modified in the browser's Developer tools search. Once you find the scripts that are making this.modified=true, you can put breakpoints, run the debugger and lookup through the stack trace to get the Client script or UI policy name which is responsible for making the modification. Some helpful resources mentioned below:

  • How to step through your code
  • How To Pause Your Code With Breakpoints In Chrome DevTools
  • View Page Resources With Chrome DevTools

Also, refer the below product documentation on UI Policy:

  • UI Policy

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.