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Description:

User with Knowledge Role not able to create Draft article using 'Translate' related link.


Steps to Reproduce: 

Impersonate user with knowledge role

Go to any published knowledge article

Click on translate, the translate from and Translate to panes are side-by-side.

Select the language and then click on the UI action "Create Draft Article",

Expected Behavior: Draft article is created under the translated versions of the article.

Actual/Unexpected Behavior: Button freezes.


Cause

Role missing in an ACL 


Solution:

Below ACL was causing this Issue.

https://<instance_name>.service-now.com/sys_security_acl.do?sys_id=756cfa0553513300343fddeeff7b1275&sysparm_nostack=true

"snc_internal" role was missing in ACL.

Importing this ACL Role association from OOB which resolved this Issue.


Additional Information:

Translate a knowledge article-

https://docs.servicenow.com/bundle/orlando-servicenow-platform/page/product/knowledge-management/task/translate-knowledge-article.html


Article Information

Last Updated:2020-07-01 00:34:24
Published:2020-07-01