Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
onSubmit script error when attempting to save a case - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • onSubmit script error when attempting to save a case
KB0830795

onSubmit script error when attempting to save a case


2154 Views Last updated : May 30, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Users encounter an onSubmit script error when attempting to save a form. In this scenario, the error arises in the Case form.

 

onSubmit script error: TypeError: Cannot read property 'display' of undefined:
function(){
return GwtListEditor._editListOnSubmitWrapper(listID);
}

Release

All releases

Cause

Duplicate entries on the question_answer table for the specific record you are trying to save.

Resolution

  1. Check to see if there is a variable editor on the form. 
  2. If there is, check to see if the questions are shown more than once. 
  3. If so, there are duplicate entries in the question_answer table that need to be removed. 
  4. Navigate to the question_answer table and filter on 'table_sys_id' is the sys ID of the form you were trying to save.
  5. Remove the duplicate entries.

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.