Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
[On-Prem] Manual upgrade fails if the assigned war value is incorrect - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • [On-Prem] Manual upgrade fails if the assigned war value is incorrect
KB0830668

[On-Prem] Manual upgrade fails if the assigned war value is incorrect


1097 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Incorrect assigned war settings can cause upgrade failures. The check upgrade script fails with the below error if the system property "glide.war.assigned" is set to an incorrect value or it has any junk character. 

SEVERE *** ERROR *** Upgrade: The desired war does not match the distribution build, desired war (without suffix): <incorrect value>, distribution build: <downloaded file version>. Upgrade will not run

Release

All Releases

Cause

Incorrect system property "glide.war.assigned" value

Resolution

Update the system property "glide.war.assigned" correctly. The value should be the name of the newly downloaded zip file. Make sure to add the .zip extension as well. Any incorrect value can cause Check Upgrade Script failure with the error mention in the description. It leaves the node version and DB version in an incorrect state.


Example:

If the downloaded zip file is : glide-orlando-12-11-2019__patch3-04-22-2020_05-05-2020_1854.zip

Then glide.war.assigned should be set to "glide-orlando-12-11-2019__patch3-04-22-2020_05-05-2020_1854.zip" 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.