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RITM's flow is not triggering - Support and Troubleshooting
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  • RITM's flow is not triggering
KB0829282

RITM's flow is not triggering


2729 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

  • RITM's flow is not triggering
  • RITM's flow is not firing
  • RITM's flow is not launching
  • after the RITM's stage is request approved the flow did not trigger

In the system logs we see the following:

com.glide.plan.runners.FlowObjectAPIException: The flow named: <flow_display_name_here> has not been published within application scope: global
Caused by error in sys_script_include.8f3a2778c0a8002700fbde5ad148abe3.script at line 54
com.glide.plan.runners.PlanRecordRetriever.getPlanRecord(PlanRecordRetriever.java:49)
com.glide.plan.runners.FlowObjectInstanceFactory.createFlowObjectInstance(FlowObjectInstanceFactory.java:23)
com.glide.plan.runners.scriptable.ScriptableFlow.jsStaticFunction_startAsync(ScriptableFlow.java:40)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
java.lang.reflect.Method.invoke(Method.java:498)
...

Cause

  • this happens when the flow is deactivated in the designer
  • the active flag on [sys_flow_catalog_trigger] is set to false
  • when the RITM's stage to set to "request_approved" the SC bus.rule tries to launch the cat item's flow and the error is thrown

Resolution

  • Open the flow in flow designer, and activate the flow

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