Issue
Users are unable to open attachments from Service Portal. Clicking on the URL does not appear to do anything, and does not download any attachments.
Release
All releases
Cause
This has been known to happen when a forward slash "/" is placed after the portal name. For example:
https://your_instance.service-now.com/portal/?id=kb_article&sys_id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Resolution
To correct this behavior, change this:
https://your_instance.service-now.com/portal/?id=kb_article&sys_id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
To this (by removing the forward slash after the portal name):
https://your_instance.service-now.com/portal?id=kb_article&sys_id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx