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Menu Item in Service Portal not getting Translated - Support and Troubleshooting
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  • Menu Item in Service Portal not getting Translated
KB0827161

Menu Item in Service Portal not getting Translated


1071 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When changing the language to French (or whatever language is installed), the Menu Item is not getting translated:

Example

Release

Verified in New York but could happen in any version

Cause

This usually happens when adding new menu items into the Service Portal since the translation is not there

Resolution

To add the translation please follow the following steps:

1. Open the sys_translated_text list table
2. Click on New
3. Select the table name "Menu Item [sp_rectangle_menu_item]
4. Field Name: "Label"
5. Language: French
6. Click on the Magnifying glass for Document and here you will look for by clicking on the Magnifying glass and finding in this case "Knowledge" menu item that is related to SP. Click okay
7. Value: Put the translate text in French


8. Save the record

Now switching the language in Service Portal should display the correct Menu language.


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