Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
The user name is not visible in dashboard share option - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • The user name is not visible in dashboard share option
KB0826909

The user name is not visible in dashboard share option


895 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

The dashboard "ABCD" is shared for different users with the sharing function of the dashboard. Later, the users of the dashboard are not visible in sections All, Users. 

Below is the screenshot for reference. 

Release

All

Cause

The issue occurs as a result of a duplicate user entry when the dashboard has been shared. 


Whenever the dashboard is shared, an entry is placed into the 'pa_dashboards_permissions' table. 
At some point, it may have caused that a specific user has been added twice. Below is the screenshot for reference. 

Resolution

1. Login to instance and navigate to pa_dashboards_permissions.LIST 

2. Search with the dashboard name = 'ABCD' and you should notice records

3. Identify and remove the duplicate entry for the users.

4. Validate the dashboard again and the user list should get displayed now. 

Related Links

https://docs.servicenow.com/csh?topicname=c_DashboardRoles.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.