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SAML properties prompts to upgrade even though Multiple Provider Single Sign-On Installer is already installed - Support and Troubleshooting
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KB0826313

SAML properties prompts to upgrade even though Multiple Provider Single Sign-On Installer is already installed


486 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

You will recognise this issue by the following prompt in the SAML 2.0 properties page

SAML 2.0

 

However the Multi Provider SSO plugin is already installed

 

On Checking the SAML 2.0 Installation Exits 

  • SAML2Logout
  • SAML2Logout_update1
  • SAML2SingleSignon
  • SAML2SingleSignon_update1

It is observed that they are still active

 

Cause

If there is an existing SAML2 Update1 configuration when the Multi Provider SSO plugin is installed the existing IdP details are migrated into the plugin.

This will create a SAML 2 Migrated IdP record within Multi Provider SSO.

However we do not automatically enable this in order to allow verification of the configuration prior to switching over to the new plugin.

Until the Multi Provider SSO plugin is enabled you are still using the SAML 2 configuration and will see this message as a reminder.

Resolution

To activate the Multi Provider SSO plugin , check the relevant box in the Properties page

Checking this will

  • deactivate the SAML 2 installation exits,IdP etc,
  • remove the SAML2 application from the navigator
  • activate the Multiple Provider SSO installation exits, IdP etc

NOTE: If you have changed your IdP configuration since the Multi Provider SSO plugin was installed then the migrated IdP record will be incorrect.

You can run a repair on the plugin installation to have a new migrated IdP record created

Related Links

For more information, see the following Documentation topics:

External single sign-on (SSO)

Installation Exits

Changes to SAML 2.0 and digest token configuration


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