Issue
Discovery scan for Kyocera printer runs successfully but doesn't capture printer Name field on OOB.
Note:- This is a custom implementation.
Release
Orlando and older
Cause
Kyocera Printers doesn't respond to OOB sysName OID but respond to OID 1.3.6.1.4.1.1347.40.10.1.1.5.
Resolution
- Create new custom code Probe and sensor for processing Kyocera printer name.
- Refer sample code at sensor attached
- On Probe, add SNMP fields (command =Walk and OID=1.3.6.1.4.1.1347.40.10.1.1.5
- This new sensor is updating Name for one of the Printer model
- Restart the MID Servers
Related Links
Check if Kyocera MIB is inactive.
If MIB is active, edit sensor code to
var nameOID = snmp.getOIDText('iso.org.dod.internet.private.enterprises.kyocera.unk_40.unk_10.unk_1.unk_1.unk_5');