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Change request risk is showing as empty after insertion of record - Support and Troubleshooting
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  • Change request risk is showing as empty after insertion of record
KB0824742

Change request risk is showing as empty after insertion of record


701 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

A change request is created from the standard template then the change record is showing the risk as low which is a default value set in the dictionary but after the record insertion the risk field value is being empty or null

Steps to reproduce:

1.Set the risk field to readonly in dictionary and the default value is low

2.Configure a template with the fields having value

3.Open the template where the change request will be created

4.Check the risk field if the value is set to low or not

5.save the request

6.Check the risk value in the request

Cause

There is a property which is used to check the fields mentioned in that property to see if they are present in the template and assign that value to the field based on the value in the template by

The above-mentioned value setting process for readonly  is done by the business rule 'Restrict fields from Standard Change' which is calling the script include 'StdChangeUtilsSNC' and setting the read-only values

Resolution

Check the read only property in the below mentioned link
https://<instance-name>.service-now.com/std_change_properties.do?sys_id=527b5dafff700200b18affffffffff89&sysparm_view=&sysparm_record_target=std_change_properties&sysparm_record_row=1&sysparm_record_list=&sysparm_record_rows=1

As there is no value set for the risk field in the template it sets the value as empty or null;

Business rule : Restrict fields from Standard Change

https://<instance-name>.service-now.com/sys_script.do?sysparm_record_rows=107&sysparm_record_list=collection%3Dchange_request%5EORcollectionINchange_request%2Ctask%5EORDERBYDESCsys_updated_on&sysparm_record_row=3&sysparm_record_target=sys_script&sysparm_view=&sys_id=ddfb8160938102009ca87a75e57ffbb4&sysparm_nostack=true
 
Script include : StdChangeUtilsSNC
 
https://<instance-name>.service-now.com/nav_to.do?uri=%2Fsys_script_include.do%3Fsys_id%3Df10d6bf3931002003b7a7a75e57ffb73%26sysparm_view%3D%26sysparm_domain%3Dnull%26sysparm_domain_scope%3Dnull

 

Related Links

The other possibilities where the risk value is being set to empty

check if there are any client scripts which are setting the risk field to empty

check if there are any Business rules which are setting the risk field to empty


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