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After Updating the Status field of Asset to retired, Operational Status of CI not getting updated. - Support and Troubleshooting
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  • After Updating the Status field of Asset to retired, Operational Status of CI not getting updated.
KB0824647

After Updating the Status field of Asset to retired, Operational Status of CI not getting updated.


7712 Views Last updated : Apr 8, 2025 public Copy Permalink English (Original)
  • English (Original)
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KB Summary by Now Assist

Issue

  • The operational status field on the CMDB CI table is not getting updated when an asset status is updated to retired.
  • Logically when an asset is set to retired state, it sets to install_sttaus, hardware_status, and Operational_status to retired. But here the same was not working.

Cause

  • While reproducing this issue, we observed below error in system logs
ci_state_management : UNPRIORITIZED_OPS_STATE: Unprioritized operational state [Retired]
Failed to update Operational Status via business rule
ci_state_management: Failed to update Operational Status via business rule: no thrown error
ci_state_management : UNPRIORITIZED_OPS_STATE: Unprioritized operational state [Retired]: no thrown error
  • We investigated this further and found that "Sync Ops Status for CMDB CI" business rule and some/all records on "statemgmt_ops_state_pri" tables are missing.

Resolution

  • In order to fix this issue, the attached files are imported on the impacted instance. 
  • The files contain "Sync Ops Status for CMDB CI" BR and configuration records on "statemgmt_ops_state_pri" table. After making these changes, the operational status is syncing without any issue. Below is the expected result.

  • Note: This issue may happen for other status transitions as well so the above solution can be checked/validated.

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Attachments

Attachments

  • Pasted image.png
  • statemgmt_ops_state_pri (1).xml
  • sys_script_4beeade3dbb33300a597307e7c96194d.xml

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