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The column "Category" appear to be free text, instead of selection / drop down list in TCP portal - Support and Troubleshooting
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  • The column "Category" appear to be free text, instead of selection / drop down list in TCP portal
KB0824506

The column "Category" appear to be free text, instead of selection / drop down list in TCP portal


461 Views Last updated : Aug 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When we change the column "category" to "data.editable_fields" in Time Card Grid - https://<instanename>.service-now.com/nav_to.do?uri=sp_widget.do?sys_id=191df3b393332200ea933007f67ffbab Server script - Ln 80.
The column "Category" appear to be free text, instead of selection / drop down list

Cause

This is to provide customers to view additional fields.https://docs.servicenow.com/csh?topicname=add-columns-to-time-card-list.html&version=latest
But on this, there are customization made to get this column editable
Time Card Grid - https://jp.service-now.com/nav_to.do?uri=sp_widget.do?sys_id=191df3b393332200ea933007f67ffbab
Server script - Ln 80

Unfortunately, OOB infrastructure is not in place to make columns editable the 2 fields that Project time category and Resource plan are implemented to be editable. For this to achieve it requires a lot of code changes other than the change mentioned above.
If you want category as dropdown then that will have to have custom logic for dropdown similar to how Project time category and Resource plan are implemented OOB.

Resolution

Allowing editing any custom field is challenging considering that you can configure any type of field like here expectation is simple text instead of drop.
At present adding any new columns is supported with only read-only view.


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