Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Survey is not generated - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Survey is not generated
KB0824412

Survey is not generated


751 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Survey stopped generating even if the Trigger condition is satisfied

Release

Any

Cause

The "Category Assessable Records" which is the relationship between Metric Category and Assessable Record is missing or was not generated due to a customization.

 

Resolution

To solve the issue, add an entry in [asmt_m2m_category_assessment]

Populate with the survey name, category, and the domain of the survey

Related Links

Ideally, the survey that was created from survey design should have automatically generate the [asmt_m2m_category_assessment] record

Check how the survey was created and check any customizations running during the creation


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.