Notifications

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Description

The 'Add customer role to contacts' business rule was modified in New York causing the the "sn_customerservice.customer" role to users unexpectedly. This role prevents the users from performing work.

Release or Environment

New York

Cause

Changes to the 'Add customer role to contacts' business rule caused users on customer_contact table to be assigned the 'sn_customerservice.customer' role. The business rule runs on the customer_contact table. Internal users should not be defined on the customer_contact table, but should be on sys_user table instead.

Resolution

Ensure internal users are defined on sys_user table and external users on customer_contact table.

Article Information

Last Updated:2020-05-04 16:22:20
Published:2020-05-04