Issue
The instance displays the errors as "Failed to write file [ logo ] to database: no thrown error " in the system Logs when the user navigates to System Applications > My Company Applications module .
Release
Newyork and Orlando
Cause
This is impacted by the PRB1367582 [NewYork: sn_appclient.LogoDownloader is generating "Failed to write file [ logo ] to database" error in System logs]
Resolution
Since these errors are only "noise" and do not seem to have any functional impact, they can be safely ignored.