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Knowledge Manager unable to edit articles in the Knowledge Base - Support and Troubleshooting
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  • Knowledge Manager unable to edit articles in the Knowledge Base
KB0823383

Knowledge Manager unable to edit articles in the Knowledge Base


1367 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Knowledge Manager or Admin is unable to edit articles in the Knowledge Base as they are unable to see the CheckOut option.

Release

New York

Cause

Below check is failing:

if(this._getCheckedoutRecord(current))
return false;

/**
* Check and return if there is another version of the record active
* For eg:- workflow_state=draft/review
*
* @param GlideRecord: current
* @return GlideRecord
**/
_getCheckedoutRecord: function(current){
var gr = new GlideRecord(this.KB_KNOWLEDGE);
gr.addQuery('article_id',current.article_id);
gr.addQuery('sys_id','!=',current.sys_id+'');
gr.addQuery('workflow_state','NOT IN',this.WORKFLOW_COMPLETED_STATES.join(','));
gr.setLimit(1);
gr.query();
if(gr.next())
return gr;
else
return false;
},


- The KB ARticle version is in RETIRED State.
- The KB Articles has other versions that are Retired. i.e not in ['published','outdated'] state. Due to this, this method evaluates to true and 'canCheckout' Function returns false.

Resolution

Move the older KB Articles Versions(of all the non-working Articles) from Retired to Outdated in order to fix this issue.


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