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On-Call Manage Shift cannot change on-call more than once - Support and Troubleshooting
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  • On-Call Manage Shift cannot change on-call more than once
KB0823252

On-Call Manage Shift cannot change on-call more than once


7740 Views Last updated : Jan 28, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

In On-Call, when you click on 'Manage Shift', change the on-call, it will not allow you to change if you have already modified it previously

1. Open On-Call Calendars
2. Choose any group
3. Choose Day view
4. Right-click a schedule and choose Manage Shift
5. Set the following: Action Provide Coverage, Choose a roster, Change the current Member, Click Schedule.
6. Confirm that the On-Call person has changed for that shift.
7. Repeat the above, and change to a different person or back to the original person

Release

Any

Cause

This is the expected behaviour of the Manage Shift function in the On-call Calendar.
It will be reading the table [cmn_schedule_span] and the Manage Shift will not delete this record, thus the messages below can occur

"Some Coverages spans were not created since they already have a Coverage defined"

"Coverage creation skipped"

"conflicting coverage present"

Resolution

1. Go to the [cmn_schedule_span] record list view and filter in the group name where you want to change the on-call person

2. You can delete the record created by the Manage Shift

3. Once deleted, the On-Call 'Manage Shift' can now modify the on-call person



Related Links

User need to delete old coverage, if the user wants to replace existing defined coverage member with a new one.

If you don't delete old coverage and create a new one on top of it, then it can potentially create issue while determining "who is on-call". As you will be having multiple coverage records for same period of time.

We also have the "Replace coverage" Action on calendar shown in shift span. You can use that option, instead of creating a new coverage


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