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Cant configure Portfolio as Mandatory in SAFe Epic - Support and Troubleshooting
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  • Cant configure Portfolio as Mandatory in SAFe Epic
KB0823176

Cant configure Portfolio as Mandatory in SAFe Epic


393 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When we change the application scope to Portfolio SAFe to create UI Policy / Data Policy for configuring the Portfolio field mandatory, the Mandatory field on UI action is disable or read-only.

Check the record in sys_ui_policy_action 

Cause

The field is set to Read-only by below OOB client script.
https://<instancename>.service-now.com/sys_script_client.do?sys_id=714c95603712210066512f3c8e41f104

The above is an OOB client script "disable mandatory onload for outofscope". The dictionary entry has been modified to not make it mandatory by default in the dictionary configuration
https://<instancename>.service-now.com/history.do?sysparm_sys_id=7c1d36a6db9f8050c4939247db961928&sysparm_table=sys_dictionary&sysparm_view=safe&sysparm_nostack=true

In OOB, by default, it is mandatory in the dictionary. The reported behavior is seen in OOB as well, and it is expected as per the configuration.
Dictionary for portfolio is in “Portfolio SAFe” scope
https://<instancename>.service-now.com/sys_dictionary.do?sysparm_referring_url=sn_safe_epic.do%3Fsys_id%3Def43cc91dbe7cc50c4939247db961926%4099

Table sn_safe_epic table is in “SAFe” scope
https://<instancename>.service-now.com/nav_to.do?uri=%2Fsys_db_object.do%3Fsys_id%3D6c6abeeadb1f8050c4939247db961945

So while creating a UI policy action for field portfolio created in Portfolio SAFe, since the table is in a different scope, the client script is restricting the write on the Mandatory field. If you do a vice-versa, the same thing would happen and you will not be able to select the field itself, from the drop-down since the field is in Portfolio SAFe scope

Resolution

The behavior is seen in OOB as well, and it is expected as per the configuration.


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