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Description

The non-admin user does not see the "Subscribe" button in the knowledge portal(kb) and not able to subscribe to the knowledge articles.

Release or Environment

Service portal

Cause

The system properties "glide.knowman.enable_km_subscription.roles" manages the users who can see the subscribe button in knowledge portal.

Resolution

In OOB, the property 'glide.knowman.enable_km_subscription.roles' is set to the role 'knowledge'. Edit this property to show the subscribe button to other role users as well.

Additional Information

Refer the below docs for more details:

https://docs.servicenow.com/bundle/orlando-servicenow-platform/page/product/knowledge-management/task/configure-subscription-properties.html

Article Information

Last Updated:2020-04-28 18:23:32
Published:2020-04-29