Issue
The Knowledge homepage ($knowledge.do) Tags section is including the count of unpublished/retired knowledge articles
This caused a discrepancy on the Tags count and the knowledge articles displayed which are all only published articles
Steps to Reproduce:
1. Go to Knowledge homepage ($knowledge.do)
2. Look at several articles under the same category.
3. Assign the same tag to several of them.
4. Browse under the 'Tags' section for the tag you created and assigned. See the count for the tag.
5. Retire one or more of the articles. The count is the same next to the tag, but the end-user can only see the published articles.
Release
Any
Cause
This is the expected behaviour for the $knowledge.do page. It includes the unpublished articles in the count
Resolution
Please review the same feature on the KM Service Portal - Configure the Knowledge Management Service Portal
We support the Tag as a facet in the KM Portal search results - Configure filter facet widget instance options
The KM Service portal allows configurability and customizability (unlike the $knowledge.do page) -- so you should be able to make the desired changes.
We are unfortunately no longer making active changes into the $knowledge.do page