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CMDB CI Relationships are not visible on the Load Balancer Service Record after successful discovery - Support and Troubleshooting
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KB0822934

CMDB CI Relationships are not visible on the Load Balancer Service Record after successful discovery


1654 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

After the successful discovery of a Load Balancer, the following relationships can be seen to be created in the cmdb_rel_ci:

1)'Used by: Uses'  -> load balancer service(cmdb_ci_lb_service)  and the load balancer pool(cmdb_ci_lb_pool)

2) 'Runs on: Runs' -> load balancer service(cmdb_ci_lb_service)  and load_balancer(cmdb_ci_lb)


But the above relationships is not visible on the the cmdb_ci_lb_service CI Record in the relationship view.

Release

All

Cause

There is a 'cmdb_rel_filter' table where there are entries which filters out the relations for Load Balancers, their respective Service and Pools This is an OOTB (out-of-the-box) behaviour. 
Please refer the screenshot below:

The above filters out the relationships, restricting it to be visible on the CI Record although there are valid relations in the cmdb_rel_ci table.

Resolution

Set the 'active' field to 'false' for the entries related to Load balancer under 'cmdb_rel_filter' table for the upstream and downstream relations for the Load Balancer devices to be visible. The dependency map view will also be shown for the load balancer service records.




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