Notifications

36 views

Description

The MID Server fails to detect glibc version when it is running on Ubuntu 14.04+ in New York. Specific to New York Patch 8, with glibc detection failure, MID Server can fail to upgrade.

The MID Server will log a MID Server issue for incompatible glibC version and prevent upgrade.  This is due to new ServiceNow OpenJRE 1.8.0_231-sncmid1 which has a minimum JRE version requirement to be 2.12 on a Linux host.



Steps to Reproduce

  1. Install a MID Server on an Ubuntu host (any version lower than New York patch 8).
  2. Auto upgrade will start once the ServiceNow instance is upgraded to New York patch 8.
  3. Auto upgrade will not be able to figure out the glibC version and therefore will fail the upgrade process.
  4. A MID Server issue will be logged.
  5. You can continue to use the MID Server.

 

Workaround

The workaround is to wait for the New York patch 9 (issue is specific to Ubuntu).

You can also manually upgrade the MID Server by downloading from the ServiceNow instance. For more information, see KB0713557.

 




Related Problem: PRB1351473

Seen In

There is no data to report.

Fixed In

New York Patch 9
Orlando

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2020-04-24 10:32:41
Published:2020-04-24