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Unable to attach document to the KB article. - Support and Troubleshooting
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  • Unable to attach document to the KB article.
KB0822264

Unable to attach document to the KB article.


1323 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Post Orlando, users are unable to attach the document to the KB article , when the status of the article is set to published, retried, out_dated . 

Cause

Client script onload "Hide Attachment Link when read only" introduced in Orlando which is limiting the attach button

Resolution

This is the expected behavior. When an article is in Published state, the form is read-only until the article is checked out. Then a new version is created and you can add attachments to the new version.

That is the intended behavior with knowledge versioning enabled, if you wish to add attachments or make edits then they can disable versioning feature or disabling the client script.


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